Urgent DraftSight Critical Hotfix

Are you using DraftSight on a Windows based PC? If so, read on, you’ll need to run this fix as soon as possible. Basically, there is an issue with an Expired Certificate. What does that mean? Well it means that as of March 1st 2017, all versions of DraftSight released from 2012 to 2017 SP0 …

Urgent DraftSight Critical Hotfix Read More »